This project is read-only.

Ad Rotator in SP2010

Nov 3, 2010 at 6:51 PM

I downloaded the application and followed the instructions for the installation.  I activated the feature, etc.  I was able to create the advertisement list and upload images.  I added the Ad Rotator web part to the page, but as soon as I tried to go to the web part page, I get the following message:

Cannot make a cache safe URL for "1033/pickertreedialog.js", file not found. Please verify that the file exists under the layouts directory.


The only thing I changed (other than the URL and location of the download) is that I downloaded both version 2007 and 2010.  Since they are the same, I changed the filename to SectorPoint.Products.AdRotator-SP2010.wsp (and SP2007 for that version).  This is what I had to use when I added and deployed the solution.  Did this cause the problem?


Any other ideas you can give me?





<script type="text/javascript">// <![CDATA[ var gearPage = document.getElementById('GearPage'); if(null != gearPage) { gearPage.parentNode.removeChild(gearPage); document.title = "Error"; } // ]]></script>

Nov 30, 2010 at 7:23 AM
Edited Dec 1, 2010 at 3:21 AM

I too am suffering this problem, Sharepoint 2010. Sadly I'm a complete n00b on SharePoint matters, but I have no idea how to troubleshoot these issues and would appreciate any help.


Kindest Regards,


Feb 18, 2011 at 6:14 PM

Followed instructions as well and got same result.

Using Foundation, does that matter?

Sep 6, 2011 at 7:31 AM

same problem here "Cannot make a cache safe URL for "1033/pickertreedialog.js", file not found. Please verify that the file exists under the layouts directory." running SharePoint foundation in a multitenancy configuration.  WSP deployed fine was able to add the feature to a feature set, but i get the same error message.

Any assistance or recommendations.

Sep 27, 2011 at 12:17 PM


Same problem here. There is no pickertreedialog.js on Sharepoint Foundation 2010.
Perhaps the listpicker function new in version 2 is responsable for this error?

Please help!!

Kind Regards,


Oct 20, 2011 at 10:39 AM

I am using Sharepoint foundation and getting the same error. Please help me!!!